Issue on Woo5.simpleservers.co.uk Wednesday 5th February 2025 11:00:00


We are aware of an issue on Woo5.simpleservers.co.uk. Our senior engineers are currently looking into this and we will provide a further update on this shortly.

We apologise for any incontinence this has caused you.

Update: We can confirm that the service is back up after the issue has been identified and resolved.