Issue Affecting Cloud Servers Tuesday 21st September 2021 11:25:00


2021-09-21 11:25

We're currently investigating an issue with the Cloud platform that is affecting some servers.

Updates will be posted as this issue is progressed.

2021-09-21 11:55:

All affected servers are now back up and running. If anyone encounters any issues, please get in touch by opening a ticket from your client area with us.